Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

Ошибка при перекодировке строки windows-1251 - utf-8 (библиотека Encode) (Lvovich)
Author Message
Lvovich
Участник форума



Joined: 24 Jun 2004
Posts: 45
Карма: 0
   поощрить/наказать


PostPosted: Wed Jun 02, 2010 11:47 am (написано за 2 минуты 30 секунд)
   Post subject: Ошибка при перекодировке строки windows-1251 - utf-8 (библиотека Encode)
Reply with quote

Использую ActivePerl (расширение Денвера), код такой:
Code (perl): скопировать код в буфер обмена
use Encode;
Encode::from_to($bb, 'windows-1251', 'utf-8');
Получаю ошибку:
Code (any language): скопировать код в буфер обмена
[Wed Jun 02 12:38:44 2010] [error] [client 127.0.0.1] Encode object version 2.12 does not match bootstrap parameter 0.00 at Z:/usr/local/perl/lib/XSLoader.pm line 94.
На сети все работает.
Помогите, пожалуйста, разобраться - в чем причина?
Back to top
View user's profile Send private message Send e-mail
Lvovich
Участник форума



Joined: 24 Jun 2004
Posts: 45
Карма: 0
   поощрить/наказать


PostPosted: Mon Jun 07, 2010 7:09 pm (спустя 5 дней 7 часов 22 минуты; написано за 2 минуты 19 секунд)
   Post subject:
Reply with quote

Вот, нашел кое-что:
Quote:
How to I prevent "object version X.XX does not match bootstrap parameter Y.YY" errors?XS code is very sensitive to the module version number and will complain if the version number in your Perl module doesn't match. If you change your module's version # witho
Гугл перевел:
Quote:
Как я могу предотвратить "объект версии X. XX не соответствует загрузочный параметр Ю. YY" ошибки? XS код очень чувствителен к модулю номер версии и будет жаловаться, если номер версии в модуль Perl не совпадают. Если вы измените версию вашего модуля # witho
Уважаемые разработчики, может, необходимо перекомпилировать Active Perl, который идет с Денвером?
(это, конечно, мысли чайника, если я не прав, не злитесь на меня)
Back to top
View user's profile Send private message Send e-mail
Ant
Сотрудник «Лаборатории»



Joined: 17 Jun 2003
Posts: 6837
Карма: 131
   поощрить/наказать


PostPosted: Tue Jan 24, 2012 11:12 am (спустя 1 год 7 месяцев 16 дней 16 часов 2 минуты; написано за 20 секунд)
   Post subject:
Reply with quote

Lvovich wrote:
Уважаемые разработчики, может, необходимо перекомпилировать Active Perl, который идет с Денвером?
Скачайте последнюю версию перла с ActiveState.com и установите самостоятельно.
Back to top
View user's profile Send private message Send e-mail
Lvovich
Участник форума



Joined: 24 Jun 2004
Posts: 45
Карма: 0
   поощрить/наказать


PostPosted: Tue Jan 24, 2012 12:43 pm (спустя 1 час 31 минуту; написано за 12 секунд)
   Post subject:
Reply with quote

Браво!
Back to top
View user's profile Send private message Send e-mail
Ant
Сотрудник «Лаборатории»



Joined: 17 Jun 2003
Posts: 6837
Карма: 131
   поощрить/наказать


PostPosted: Tue Jan 24, 2012 3:03 pm (спустя 2 часа 19 минут; написано за 1 минуту 26 секунд)
   Post subject:
Reply with quote

А что ещё вы хотели услышать? Что разработчики сейчас всё бросят и будут обновлять пакет дополнения с Active Perl с каждым его выпуском? Ставите свежий Денвер и на него ставите свежий Active Perl. Последний устанавливается элементарно прямо на Денвер.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Page 1 of 1    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You cannot download files in this forum.
XML