Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

[bogus] Не работают все хосты, кроме localhost. (Илюха, оценка: 6)
Goto page Previous  1, 2, 3, 4  Next
Author Message
Valpet
Guest





Карма: 386
   поощрить/наказать


PostPosted: Mon Jun 28, 2010 2:23 pm ()
   Post subject: Не работают все хосты, кроме localhost.
Reply with quote

Alhames wrote:
Если у вас работает только localhost, а другие адреса не откликаются, то:
 1. Проверте, включен ли у вас DNS-клиент: Пуск >> Все программы >> Администратирование >> Службы, находим службу DNS-клиент и смотрим Свойства. Должны стоять: Тип запуска - Авто, Состояние - Работает. 2. Проверте, изменился ли файл hosts: Открываем папку C:\WINDOWS\system32\drivers\etc, запускаем Денвер, после открываем файл hosts с помощью блокнота. В нем должно быть примерно следующее:
 с помощью блокнота. В нем должно быть примерно следующее:

   
    Код (any language):
    скопировать код в буфер обмена
  
  
127.0.0.1        localhost
127.0.0.1        www.subdomain.localhost
127.0.0.1        www.subdomain.test1.ru
127.0.0.1        subdomain.localhost
127.0.0.1        subdomain.test1.ru
127.0.0.1        www.localhost
127.0.0.1        www.test1.ru
127.0.0.2        custom-host
127.0.0.2        www.custom
127.0.0.1        test1.ru
127.0.0.2        custom
  

Если же этого нет, смотрим свойства файла: в Атрибутах не должно стоять галочки рядом с Только чтение! Прописываем нужные адреса вручную. 3. Если приведенные два шага не дали результатов, то причина может быть в обновлении Windows XP (на необновленном SP2 такой проблемы быть не должно). Единственное решение, которое действительно работает (но почему я не знаю) - это создать заново файл hosts. Делаем так: a) отключаем Денвер; b) удаляем файл hosts; c) запускаем Денвер (он должен создать новый файл hosts с необходимыми адресами); d) проверяем работоспособность перечисленных в hosts доменов.
Перепробовал делать все что написано на этом форуме, но результат все равно не изменился. Пишет:"Ошибка! Нельзя установить права на запись" И дальше: "Установка будет продолжена, однако из-за невозможности обновления файла hosts будет работать только адрес localhost/
Повторяю - переделал все что писали выше.
У меня windows 7
Back to top
Valpet
Заглянувший



Joined: 28 Jun 2010
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Mon Jun 28, 2010 2:34 pm (спустя 11 минут; написано за 1 минуту 27 секунд)
   Post subject: Не работают все хосты, кроме localhost.
Reply with quote

Перепробовал все что здесь написано, ни фига не помогает. "Не удалось установить права на запись". А раз так - то =Не работают все хосты, кроме localhost.= Ну и что-же все таки делать?
Back to top
View user's profile Send private message
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 80
   поощрить/наказать


PostPosted: Thu Jul 01, 2010 3:46 pm (спустя 3 дня 1 час 12 минут; написано за 45 секунд)
   Post subject:
Reply with quote


М

Valpet,
ну для начала... прочитать правила форума, у нас такая стилистика общения на форуме не принята.
ну и напоследок, рассказать, что именно "все" вы перепробовали...
Back to top
View user's profile Send private message Send e-mail
Turboworld
Заглянувший



Joined: 01 Jul 2010
Posts: 3
Карма: 0
   поощрить/наказать


PostPosted: Thu Jul 01, 2010 4:03 pm (спустя 17 минут; написано за 3 минуты 49 секунд)
   Post subject:
Reply with quote

Valpet wrote:
Перепробовал делать все что написано на этом форуме, но результат все равно не изменился. Пишет:"Ошибка! Нельзя установить права на запись" И дальше: "Установка будет продолжена, однако из-за невозможности обновления файла hosts будет работать только адрес localhost/
Повторяю - переделал все что писали выше.
У меня windows 7
У меня сейчас та же проблема, что и у парня - пишет что не открыть для записи файл hosts.
Только у меня WinXP SP2.

Так же как у него - при установке вылазит эта "denwer project utility", в которой написано, что вроде как всё ok, однако, когда ее закрываешь - в черном "досовском" окошке написано что не может он открыть файлик hosts.

В результате (или по каким-то другим причинам) я не могу достучаться на поднятый сервер извне.
Работает только localhost, а по внешнему айпишнику не достучаться. Да, про файрволл не говорите, уже всяко разно пробовал. Даже запрос в техподдержку KIS 2010 написал с вопросом как их дурацкий сетевой экран настроить, чтобы все работало. Потому что перепробовал все настройки. Не открывается ничего по внешнему айпи (и по домену, к нему привязанному тоже) и всё тут :(
Back to top
View user's profile Send private message
Turboworld
Заглянувший



Joined: 01 Jul 2010
Posts: 3
Карма: 0
   поощрить/наказать


PostPosted: Thu Jul 01, 2010 4:06 pm (спустя 2 минуты; написано за 2 минуты 3 секунды)
   Post subject:
Reply with quote

P.S. файл hosts - самый обычный. Галки "для чтения" не стоит, файл не скрытый. Я его удалял (переименовывал в hosts_old), но денвер так ничего мне и не создал взамен.

Может с Denwer'ом проблема в Kaspersky Internet Security 2010 (у топикстартера не стоит лли такого ПО?)?
Я уже даже не знаю, что еще можно сделать...
Back to top
View user's profile Send private message
Turboworld
Заглянувший



Joined: 01 Jul 2010
Posts: 3
Карма: 0
   поощрить/наказать


PostPosted: Thu Jul 01, 2010 4:15 pm (спустя 8 минут; написано за 1 минуту 56 секунд)
   Post subject:
Reply with quote

upd: мне помогло вот что :))
Quote:
Простой способ открытия сайта наружу
Предположим, ваш IP-адрес равен 192.168.0.49, как в примере выше. Самый простой способ заставить Денвер открывать по адресу 192.168.0.49 определенный сайт — это расположить документы сайта в директории:

/home/192.168.0.49/www

Да, имя директории содержит точки! Не забудьте также перезапустить Денвер.
Я создал дубликат папки localhost и переименовал ее в адрес своего внешнего айпишника. Теперь извне я доступен. :)

А вот про файлик hosts все так же, как и было =/
Back to top
View user's profile Send private message
Guest






Карма: 386
   поощрить/наказать


PostPosted: Sat Jul 03, 2010 9:10 am (спустя 1 день 16 часов 55 минут; написано за 12 секунд)
   Post subject:
Reply with quote

Windows 7 и Denwer 3.
Так же был доступен только локалхост, плюс хост с айпишником моего компа.
IIS отключал, антивирь отключал, к тому же у меня Аваст. В Файл hosts запись делается. В логах из ошибок только криво настроенные виртуал хосты по 443 порту. Скайпа нет вообще, все, что нашел на форуме - было проделано или в этом ошибка не крылась.
Оказалось, что все довольно просто.
У меня в файле хостс перед записями сделанными денвером стоял какой-то спецсимвол, в общем хостс выглядел так:
Code (any language): скопировать код в буфер обмена
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#        127.0.0.1       localhost
127.0.0.1 localhost
127.0.0.1 mpa.one.microsoft.com
127.0.0.1 sls.microsoft.com
127.0.0.1 genuine.microsoft.com
127.0.0.1 wat.microsoft.com
127.0.0.1 mpa.microsoft.com
127.0.0.1 activate.adobe.com
127.0.0.1 practivate.adobe.com
127.0.0.1 ereg.adobe.com
127.0.0.1 activate.wip3.adobe.com
127.0.0.1 wip3.adobe.com
127.0.0.1 3dns-3.adobe.com
127.0.0.1 3dns-2.adobe.com
127.0.0.1 adobe-dns.adobe.com
127.0.0.1 adobe-dns-2.adobe.com
127.0.0.1 adobe-dns-3.adobe.com
127.0.0.1 ereg.wip3.adobe.com
127.0.0.1 activate-sea.adobe.com
127.0.0.1 wwis-dubc1-vip60.adobe.com
127.0.0.1 activate-sjc0.adobe.com
127.0.0.1 adobeereg.com
#        ::1             localhost

127.0.0.1        localhost
127.0.0.1        www.subdomain.localhost
127.0.0.1        www.Tools.localhost
127.0.0.1        subdomain.localhost
127.0.0.1        Tools.localhost
192.168.0.1        www.192.168.0.1
127.0.0.1        www.localhost
192.168.0.1        192.168.0.1
как только убрал
Code (any language): скопировать код в буфер обмена
#        ::1             localhost

После рестарта денвера все прекрасно заработало.
Может кому будет полезно.
Back to top
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 80
   поощрить/наказать


PostPosted: Sat Jul 03, 2010 11:06 am (спустя 1 час 56 минут; написано за 16 секунд)
   Post subject:
Reply with quote

Гость,
а как это относится к багам ДЕНВЕРА?
Back to top
View user's profile Send private message Send e-mail
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Sat Jul 03, 2010 1:04 pm (спустя 1 час 57 минут; написано за 1 минуту 1 секунду)
   Post subject:
Reply with quote

Александр Михалицын, да ладно, в заголовке темы же метка «bogus».
Тут в теме практически все сообщения такие.
Back to top
View user's profile Send private message
Guest






Карма: 386
   поощрить/наказать


PostPosted: Sat Jul 03, 2010 1:45 pm (спустя 41 минуту; написано за 1 минуту 10 секунд)
   Post subject:
Reply with quote

Александр Михалицын, если мой пост не в тему - удаляйте. На то вы и Модератор.
Но, как правильно заметил bæv, в этой теме почти все сообщения такого рода. Потому сюда и запостил, может еще у кого проблема именно в этой же фигне.
Back to top
e-rider
Guest





Карма: 386
   поощрить/наказать


PostPosted: Sat Jul 03, 2010 1:54 pm (спустя 8 минут)
   Post subject: не доступно редактирование hosts
Reply with quote

У меня тоже самое - денвер запускается, но работает только localhost.
И у меня это 100% из-за KIS2010 - только делаешь приостановку защиты, рестартишь денвер и с хостами всё ОК :) Далее можно защиту возобновить и спокойно работать 8)
Back to top
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 80
   поощрить/наказать


PostPosted: Sun Jul 04, 2010 8:06 am (спустя 18 часов 12 минут; написано за 35 секунд)
   Post subject:
Reply with quote

Гость,
Quote:
На то вы и Модератор.
Ой. Побольше бы нам таких сговорчивых пользователей.

Пусть будет - надеюсь, кому-нибудь поможет.
Back to top
View user's profile Send private message Send e-mail
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Fri Jul 09, 2010 1:11 pm (спустя 5 дней 5 часов 4 минуты)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «мусор, не относящийся к теме»,
расположенную в форуме Мусоропровод (09 Июля 2010, 14:11).
Back to top
View user's profile Send private message
heed
Участник форума



Joined: 03 Jan 2010
Posts: 97
Карма: 8
   поощрить/наказать


PostPosted: Sat Aug 21, 2010 10:00 am (спустя 1 месяц 11 дней 20 часов 49 минут; написано за 14 секунд)
   Post subject:
Reply with quote

Ilya wrote:
У меня ХР 64 bit на диске Д стоит. Никак не могу найти этот HOSTS...
Quote:
Откройте меню Пуск, выберите пункт Выполнить, введите команду %systemroot%\system32\drivers\etc и нажмите кнопку ОК.

Примечание. Если используется 64-разрядная версия Windows, введите команду %systemroot%\SysWOW64\drivers\etc.
support.microsoft.com/kb/972034
Back to top
View user's profile Send private message
dimnsk
Заглянувший



Joined: 31 Aug 2010
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Tue Aug 31, 2010 10:43 pm (спустя 10 дней 12 часов 43 минуты; написано за 4 минуты 16 секунд)
   Post subject:
Reply with quote

В поиск ходил форум рыл... Раньше стояла XP все работало тут решил на win 7 поставить

кроме klocalhost и 127.0.0.1 ничего не открываается

0. telnet localhost 80 отвечает
1. nestat порт 80 не занят skype отключен
2. прокси отключен
3. DNS включен
4. hosts удалял (денвер видит и пишет в него)
5. Антивирус снесен.


ничего не изменилось... локалхост открыается и все
что еще попробовать?

UPD: запустил еще раз и заработало ... мистика.
буду теперь перезагружаться ставить антивирус и тд..
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Tue Sep 14, 2010 10:56 pm (спустя 14 дней 13 минут)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «php подхватил не те библиотеки»,
расположенную в форуме Мусоропровод (14 Сентября 2010, 23:56).
Back to top
View user's profile Send private message
vorg666
Заглянувший



Joined: 04 Nov 2010
Posts: 2
Карма: 0
   поощрить/наказать

Location: Italy, Rimini

PostPosted: Thu Nov 04, 2010 3:53 am (спустя 1 месяц 19 дней 4 часа 56 минут; написано за 17 минут 56 секунд)
   Post subject:
Reply with quote

Здравствуйте форумчане
Два дня назад я установил на свой ноут денвер (ОС Win XP Sp3). Всё прекрастно работало целый день. На следующий день запускаю денвер и открывается только localhost (в общем как и у всех в этом топике).
Последние действия, которые я совершал после последней нормальной работы денвера:
>запуск программы iTunse от Apple
>запись файлов на iPhone через выше указанную программу
>установка новой темы для Windows
>установка программы для конвертации видео и её использование
>просмотр видео

Проделанные мною действия при обнаружевании проблемы:
>проверка службы DNS
>удаление файла hosts и проверка работы денвера в нём (денвер без проблем создаёт файл и добавляет в него записи)
>проверка не включен ли прокси
>удаление программы bonjour связанной с iTunse
>переустановка денвера
>проверка не включены ли серверы Windows-a
>отключениевсех возможных антивирусов и фаерволов
>и на конец откат системы до момента, когда денвер уже был установлен и нормально работал

Вопросы:
> что можно ещё сделать чтобы устранить ошибку?
>есть ли смысл откатывать систему до момента, когда денвер ещё не был установлен

Зарание всем спасибо за ответы.
>удаление
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Thu Nov 04, 2010 11:27 am (спустя 7 часов 34 минуты; написано за 3 минуты 29 секунд)
   Post subject:
Reply with quote

vorg666
1) попробуйте попинговать хосты при запущенном денвере
2) попробуйте сделать
Code (Windows BAT file): скопировать код в буфер обмена
ipconfig /flushdns
3) попробуйте
Code (Windows BAT file): скопировать код в буфер обмена
netsh winsock reset
но это всё стрельба наугад, к сожалению :(
Back to top
View user's profile Send private message
vorg666
Заглянувший



Joined: 04 Nov 2010
Posts: 2
Карма: 0
   поощрить/наказать

Location: Italy, Rimini

PostPosted: Thu Nov 04, 2010 3:48 pm (спустя 4 часа 21 минуту; написано за 4 минуты 58 секунд)
   Post subject:
Reply with quote

MausСпасибо.
В общем включил ноут, запустил денвер (открывался только локалхост), проверил включена ли служба DNS (была включена). Подключился к интернету и все хосты стали работать. Этого небыло вчера (в смысле, что во время подключения интернета хосты не работали), по этому не могу сказать что стало именно причиной сбоя. Я пробовал всё что мог, но не перезагружал комп после каждого действия - значит что-то всё таки помогло.

Кстате насчёт того, что денвер работает только при подключенном интернете. Это наблюдается только в Лисе, в Хроме нормально работает и с выключенным инетом.

Вот такие вот дела.

В любом случае спасибо всем, кто тут отписался и описал как он решал проблему, одно из решений мне помогло.
Back to top
View user's profile Send private message
adv17
Заглянувший



Joined: 01 Nov 2010
Posts: 1
Карма: 0
   поощрить/наказать

Location: Республика Тыва г. Кызыл

PostPosted: Fri Nov 05, 2010 2:44 pm (спустя 22 часа 55 минут; написано за 1 минуту 45 секунд)
   Post subject: Не работает Денвер3. К кому обратиться? У нас в г. Кызыле нет специалистов
Reply with quote

Здравствуйте. Это Михаил Ооржак
1. Я запустил Денвер-3.
2. Затем открыл браузер и перешел по адресу localhost, но не вошел в Денвер.
2.1. Skype - не установлен.
2.2. Антивирус - прописал x:/usr/local/apache/bin/httpd.exe в список исключений. Так-же отключал антивирус MS security essentials.
3. При каких условиях проявился баг? Что вы сделали перед тем, как его зафиксировали? - Баг не появлялся.
4. Версия OS - Microsoft Windows Версия 5.1 (сборка 2600.xpsp_sp3_gdr.100427-1636 } Service Pack 3)Корпорация Microsoft, 2007 Продукт лицензирован в соответствии с условиями Лиц. соглашения, выданного на Mikhail Home. Доступнаая физическая память 2 088 108 Kb.
5. Значимые сообщения из конца файла /usr/local/apache/logs/error.log - Прилагаю во вложении.

6. Запускался так-же - httpd.exe -w, к-ый сообщил: [Mon Nov 01 16:11:35 2010] [notice] Disabled u\se of AcceptEx<> WinSock2 API
10 Прошу помочь установить денвер, чтобы установить Joomla для создания сайта
С уважением, Михаил Ооржак
adv17@ya.ru

[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Fri Nov 05 18:31:00 2010] [notice] Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8k PHP/5.3.1 configured -- resuming normal operations
[Fri Nov 05 18:31:00 2010] [notice] Server built: Jan 9 2007 23:17:20
[Fri Nov 05 18:31:00 2010] [notice] Parent: Created child process 3568
[Fri Nov 05 18:31:00 2010] [notice] Disabled use of AcceptEx() WinSock2 API
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:00 2010] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Fri Nov 05 18:31:01 2010] [warn] Init: SSL server IP/port conflict: test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:131) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:01 2010] [warn] Init: SSL server IP/port conflict: subdomain.test1.ru:443 (X:/usr/local/apache/conf/vhosts.conf:108) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:01 2010] [warn] Init: SSL server IP/port conflict: subdomain.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:85) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:01 2010] [warn] Init: SSL server IP/port conflict: localhost:443 (X:/usr/local/apache/conf/vhosts.conf:39) vs. Tools.localhost:443 (X:/usr/local/apache/conf/vhosts.conf:154)
[Fri Nov 05 18:31:01 2010] [warn] Init: You should not use name-based virtual hosts in conjunction with SSL!!
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Child process is running
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Acquired the start mutex.
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Starting 25 worker threads.
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Listening on port 443.
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Listening on port 8648.
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Listening on port 443.
[Fri Nov 05 18:31:01 2010] [notice] Child 3568: Listening on port 80.
Back to top
View user's profile Send private message Send e-mail
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Sat Nov 06, 2010 10:51 pm (спустя 1 день 8 часов 7 минут)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «я просто перетаскивал нужную мне страницу в браузер и она работала...»,
расположенную в форуме Лень сходить в Поиск или почитать документацию (06 Ноября 2010, 22:51).
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Sat Nov 06, 2010 10:53 pm (спустя 1 минуту 59 секунд; написано за 31 секунду)
   Post subject:
Reply with quote

adv17 wrote:
Затем открыл браузер и перешел по адресу localhost, но не вошел в Денвер.
— а куда «вошли»?
Сообщения об ошибках нужно приводить дословно.
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Thu Dec 09, 2010 10:39 pm (спустя 1 месяц 2 дня 23 часа 45 минут)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «мусор»,
расположенную в форуме Мусоропровод (09 Декабря 2010, 22:39).
Back to top
View user's profile Send private message
force
Заглянувший



Joined: 28 Dec 2010
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Tue Dec 28, 2010 2:46 pm (спустя 18 дней 16 часов 7 минут; написано за 14 минут 33 секунды)
   Post subject:
Reply with quote

Внимательно прочитал эту ветку и все прочие, где могло бы быть решение проблемы. Просьба к модерам как-то отсортировать линки что ли... Везде идет ссыль на поиск по запросу (например ping) и в результатах показываются те же самые ветки, в которых всех также благополучно отправляют на форму поиска с запросом ping. Замкнутый круг в котором очень тяжело откопать первоисточник.

Перепробовал все предложенные варианты - толку ноль. Локалхост работает, прочие хосты нет.
Стал удалять денвер и обнаружил интересный факт - некоторые файлы от виртумарта не хотели удаляться/перезаписываться. Открыть их тоже было невозможно. Имена файлов shop.infopage.php shop.infopage.tpl и парочка подобных. Думал уже, что винт сыпется. Но в безопасном режиме файлы удалились.
Прогнал комп CureIT и на компе обнаружился Trojan.WinSpy.440, который засел в sfcfiles.dll. Вылечить его не удалось, только карантин. Имеющийся НОД32 тупо молчал. Оказалось, что с 21-го числа НОД32 перестал обновляться. В папке обновлений была такая же беда - файлы не открывались и не перезаписывались. Сразу стало ясно, что это проделки трояна. Не долго думая, просто сделал откат системы на дату, с которой перестал обнавляться нод32 и все заработало.

Так что проверяйте компы, возможно вирь вырубил вам денвер.
Back to top
View user's profile Send private message
Olga_from
Заглянувший



Joined: 16 Jan 2011
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Mon Jan 17, 2011 5:14 pm (спустя 20 дней 2 часа 27 минут; написано за 6 минут 7 секунд)
   Post subject:
Reply with quote

У меня было так:в файл host все прописывалось нормально, но кроме localhost никуда не могла войти. Билась и с Нодом, и с Аутпостом, читала форум. Все делала, как здесь пишут, все бестолку. А вот почему. Я пользуюсь Мозилой по умолчанию. Она тормозная, поэтому я для экспериментов взяла IE. Это ошибка моя была, потому что в Мозиле все идет!
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Wed Jan 19, 2011 3:12 pm (спустя 1 день 21 час 58 минут; написано за 52 секунды)
   Post subject:
Reply with quote

Olga_from
А Вы не пробовали обратиться в поддержку Microsoft ? Лучше всё-таки знать, почему в IE не работает
Back to top
View user's profile Send private message
Кукин
Заглянувший



Joined: 10 Feb 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Thu Feb 10, 2011 5:25 pm (спустя 22 дня 2 часа 12 минут; написано за 12 минут 41 секунду)
   Post subject:
Reply with quote

Был установлен Денвер на ОС Win7 32, проработал месяц, но недавно без видимых причин прекратил работать.
Поставил на флэшку отдельный Денвер с ПХП 5.3 - не помогло.
Работает только
localhost/denwer/
localhost/Tests/PHP5/index.php5
Всё остальное нет.

Почитал два дня форум, попробовал всё на что натолкнулся.

Нетстат - ОК
ДНС клиент - включен.
Фаерволл винды - отрубал.
Аваст - отключал.
hosts - удалял, изменяется всё нормально, атрибуты правильные.
ISS - отключена, даже специально включил и выключил.
Skype - отключен и в конфигах убраны порты
Через три кнопки прибивал все лишние процессы.
На всякий пожарный обновил виндовс, проверил после обновления с ДНС и ISS всё как положено.
localhost, 127.0.0.1 пингуется, локальные домены нет.
Прокси выключены.
netsh winsock reset - делал.
Браузеры ИЕ, Опера.
Win32DisableAcceptEx On

В голове уже каша не пойму на что грешить, помогите может затупил и что то пропустил.

Привожу листинг нетстата, апача и mysql


mysql.txt
 Description:
Mysql

Download
 Filename:  mysql.txt
 Filesize:  712 Bytes
 Downloaded:  494 Time(s)


error.txt
 Description:
Апач

Download
 Filename:  error.txt
 Filesize:  4.46 KB
 Downloaded:  790 Time(s)


netstat.txt
 Description:
По нетстату вроде проблемм нет.

Download
 Filename:  netstat.txt
 Filesize:  5.08 KB
 Downloaded:  820 Time(s)

Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Fri Feb 11, 2011 3:08 am (спустя 9 часов 43 минуты; написано за 3 минуты 20 секунд)
   Post subject:
Reply with quote

Кукин, Вы в курсе, что у Вас запущен сервер удалённого доступа к компьютеру (r_server.exe)?

Кукин wrote:
ISS - отключена, даже специально включил и выключил.
— можно попробовать вообще её удалить.

Кукин wrote:
Аваст - отключал.
— то же самое (попробовать удалить).

Кукин wrote:
локальные домены нет.
— значит с DNS, всё-таки, не всё в порядке. Попробуйте DNS-кэш почистить.
Back to top
View user's profile Send private message
Кукин
Заглянувший



Joined: 10 Feb 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Fri Feb 11, 2011 12:07 pm (спустя 8 часов 59 минут; написано за 3 минуты 33 секунды)
   Post subject:
Reply with quote

r_server установлен мной, нужен для управления соседним компьютером, Дэнвер работал при нём, его так же отключал во время проверок.
bæv wrote:
— можно попробовать вообще её удалить.
Не нашел как физически удалить IIS в Win7
bæv wrote:
— то же самое (попробовать удалить).
Удалил - не помогло.
bæv wrote:
— значит с DNS, всё-таки, не всё в порядке. Попробуйте DNS-кэш почистить.
ipconfig /flushdns - не помогло

Прям бермудский треугольник.
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Fri Feb 11, 2011 11:54 pm (спустя 11 часов 46 минут)
   Post subject:
Reply with quote


М

Ветка выделена в отдельную тему «Ищу, где светло»,
расположенную в форуме Лень сходить в Поиск или почитать документацию (11 Февраля 2011, 23:54).
Back to top
View user's profile Send private message
Кукин
Заглянувший



Joined: 10 Feb 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Mon Feb 14, 2011 11:53 am (спустя 2 дня 11 часов 59 минут; написано за 5 минут 28 секунд)
   Post subject:
Reply with quote

Заработал phpMyAdmin, локальные домены - нет.

Насколько я понимаю система не реагирует правильно на hosts
Один из доменов прописанных там, реальносуществующий сайт и меня сразу кидает на него вместо локального с идентичным названием.
Изначально я думал что это из за SQL но phpMyAdmin заработал.

Существуют ли в реестре или еще где то какие-то гипотетические ограничения для hosts?
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9995
   поощрить/наказать


PostPosted: Mon Feb 14, 2011 2:38 pm (спустя 2 часа 44 минуты; написано за 31 секунду)
   Post subject:
Reply with quote

Кукин wrote:
Один из доменов прописанных там, реальносуществующий сайт и меня сразу кидает на него вместо локального с идентичным названием.
— Вы считаете, что должно быть иначе?
Читайте: ru.wikipedia.org/wiki/DNS
Back to top
View user's profile Send private message
Кукин
Заглянувший



Joined: 10 Feb 2011
Posts: 4
Карма: 0
   поощрить/наказать


PostPosted: Mon Feb 14, 2011 4:02 pm (спустя 1 час 23 минуты; написано за 2 минуты 48 секунд)
   Post subject:
Reply with quote

Заработало, после наверно пятого по счёту удаления hosts (не подряд в процессе повторных мытарств) при выключенном денвере.
bæv wrote:
— Вы считаете, что должно быть иначе?
Да если есть сайт blablabla.com и прописан аналогичный в hosts, то покажет локальный из hosts.

Вообщем огромное спасибо форуму и вам, рад что удалось побороть эту мистику. :)
Back to top
View user's profile Send private message
Swaips
Заглянувший



Joined: 16 Feb 2011
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Wed Feb 16, 2011 9:44 pm (спустя 2 дня 5 часов 41 минуту; написано за 5 минут 5 секунд)
   Post subject:
Reply with quote

У меня денвер установился без ошибок, запустил, ввожу в строке браузера localhost/ или test1.ru, и все браузер совсем виснет и перестают запускаться любые другие программы, помогает только перезагрузка. Устанавливал все по инструкции, занес в антивирусе в исключения и все равно безрезультатно. В чем у меня проблема?
Заранее спасибо.
Back to top
View user's profile Send private message
ReVeS
Заглянувший



Joined: 15 Feb 2011
Posts: 3
Карма: -1
   поощрить/наказать


PostPosted: Thu Feb 17, 2011 9:38 am (спустя 11 часов 53 минуты; написано за 7 секунд)
   Post subject:
Reply with quote

у меня только локал хост не работает и 127.0.0.1 а тест1 работает в чём может быть проблема ?

перепробовал наверно всё что в этой темке написано
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Thu Feb 17, 2011 2:52 pm (спустя 5 часов 14 минут; написано за 20 секунд)
   Post subject:
Reply with quote

Стандартная диагностика (forum.dklab.ru/viewtopic.php?t=20602)
Back to top
View user's profile Send private message
viktor_anikanov
Заглянувший



Joined: 21 Feb 2011
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Mon Feb 21, 2011 11:08 am (спустя 3 дня 20 часов 16 минут; написано за 18 секунд)
   Post subject:
Reply with quote

sp1
Back to top
View user's profile Send private message
viktor_anikanov
Заглянувший



Joined: 21 Feb 2011
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Mon Feb 21, 2011 11:26 am (спустя 17 минут; написано за 12 минут 19 секунд)
   Post subject:
Reply with quote

Для windows 7 sp1(при запущенном outpust7.1 ), данная проблема решена была так(до этого раблтал только localhost и phpmyadmin):
1.Находим файл hosts(C:/Windows/system32/drivers/etc/hosts).
2.Удаляем файл hosts.
3.Запускаем denwer , лучше из папки denwer - run.exe с правами администратора(для тех кто в танке , нажимаем правой кнопкой мыши на run.exe и выбираем из списка "запуск от имени администратора).
4.После чего денвер запускается без проблем и сообщений об ошибках и автоматом создается заново файл host ..и все работает ок..
5. Правда браузер где запускаете проверку денвер может по началу ругнуться по поводу доверия к сайту, жмите продолжить и в firefoxe добавить в исключения...
Back to top
View user's profile Send private message
Trydorg
Заглянувший



Joined: 22 Feb 2011
Posts: 5
Карма: -2
   поощрить/наказать

Location: Одесса

PostPosted: Tue Feb 22, 2011 8:12 pm (спустя 1 день 8 часов 45 минут; написано за 58 секунд)
   Post subject:
Reply with quote

Философ, спасибо за информацию об отключении ISS. Помогло. :)
Back to top
View user's profile Send private message
delkaners
Заглянувший



Joined: 06 Oct 2011
Posts: 3
Карма: -1
   поощрить/наказать


PostPosted: Sat Oct 08, 2011 10:41 pm (спустя 7 месяцев 14 дней 2 часа 29 минут; написано за 1 минуту 47 секунд)
   Post subject:
Reply with quote

Работаю под win 7, перепробовал всё что написано в теме, всё равно тока localhost, всё остальное белый экран... До этого денвер работал и умер одновременно на трёх! машинах, переустановка не помогла, надоели танцы с бубном, проще поставить другой сервер.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML