Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

Как обновить PHP в Denwer до версии 5.2.6 (macsim)
Author Message
macsim
Заглянувший



Joined: 21 Nov 2006
Posts: 6
Карма: -4
   поощрить/наказать

Location: 174

PostPosted: Wed Aug 06, 2008 9:16 am (написано за 1 минуту 13 секунд)
   Post subject: Как обновить PHP в Denwer до версии 5.2.6
Reply with quote

Возможно ли обновить PHP Version 5.2.4 в Denwer, на версию PHP 5.2.6 Released и как?
Back to top
View user's profile Send private message Send e-mail
Юрий Насретдинов
Модератор



Joined: 13 Mar 2003
Posts: 8642
Карма: 198
   поощрить/наказать

Location: 007 495

PostPosted: Wed Aug 06, 2008 9:19 pm (спустя 12 часов 2 минуты; написано за 38 секунд)
   Post subject:
Reply with quote

Можно. Разворачивайте дистрибутив (zip) поверх, сохранив php.ini (если Вы там что-то меняли, конечно)
Back to top
View user's profile Send private message Send e-mail
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 83
   поощрить/наказать


PostPosted: Fri Nov 21, 2008 3:22 pm (спустя 3 месяца 14 дней 18 часов 2 минуты)
   Post subject:
Reply with quote


М

Перенесено из форума: Тестовый форум.
Перенесено в форум: Полезные советы :: Денвер.
Back to top
View user's profile Send private message Send e-mail
user2012x
Заглянувший



Joined: 30 Aug 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Thu Aug 30, 2012 11:23 pm (спустя 3 года 9 месяцев 9 дней 8 часов 1 минуту; написано за 7 минут 40 секунд)
   Post subject:
Reply with quote

А как обновить php в denver с php 4.4.4 с php до какого нибудь 5 - ого, чтобы больше ничего не трогать и базы не переносить и т.п.
php 4 наверно еще что - то нао поменять или как?
Как обновить используя дистрибутив с php.net (там версии поновее)
и из денвера с php 5? Это проще чем с php.net или нет?

И велика ли несовместимость между php 4.4 и php 5 разных версий?
Я слышал о ней и наблюдал её раз.
Скрипт работавший под php 4 не работал на хостинге с php 5.3 и о том что могут быть проблемы с совместимостью там было написано.
судя по вссему из - за функции ereg(), а может и что другое... не помню почему на неё подумал...
php 5.2 более совместим с php 4.4 чем 5.3 или как?

И что насчет версий php выше?
Back to top
View user's profile Send private message
Maus
Модератор



Joined: 29 Jun 2003
Posts: 8151
Карма: 271
   поощрить/наказать

Location: пос. Омсукчан Магаданской области

PostPosted: Fri May 17, 2013 5:11 pm (спустя 8 месяцев 17 дней 17 часов 48 минут; написано за 7 минут 55 секунд)
   Post subject:
Reply with quote

user2012x wrote:
php 5.2 более совместим с php 4.4 чем 5.3 или как?
скорее, наоборот.
Основное изменение 5.2 ->5.3 это пространства имён, имхо.
user2012x wrote:
А как обновить php в denver с php 4.4.4 с php до какого нибудь 5 - ого, чтобы больше ничего не трогать и базы не переносить и т.п.
подозреваю, что не взлетит.
но кошерный путь немногим сложнее:
0) переименовать ярлыки на рабочем столе и в автозагрузке. Сделать бэкап всего виртуального диска (считайте меня перестраховщиком). Сделать дампы всех баз (каждую - в отдельный файл), кроме служебных(mysql, pma, information_schema). Остановить комплекс.
1) поставить отдельно Денвер с PHP5, режим запуска reserve. Запустить его, проверить на работоспособность. Поменять какие-то настройки (если нужно). Завести заново пользователей в mysql и базы. Импортировать базы из дампов.
2) Остановить новый комплекс.
3) из старого комплекса перекопировать папки виртуальных хостов.
4) Запустить новый комплекс, проверить, что всё работает.
Back to top
View user's profile Send private message
artemida
Заглянувший



Joined: 14 Sep 2013
Posts: 2
Карма: 0
   поощрить/наказать


PostPosted: Sat Sep 14, 2013 5:46 pm (спустя 3 месяца 28 дней 34 минуты; написано за 3 минуты 18 секунд)
   Post subject: Как правильно обновить версию php?
Reply with quote

Прежде чем делать, я еще раз хочу узнать, как правильно обновить версию php?
Как я понимаю, нужно скачать дистрибутив новой версии php на windows.php.net/download/ (но, там много ссылок на скачивание, что именно нужно качать?),
затем распаковать в C:WebServes/usr/local/php5,
предварительно удалив все файлы, кроме php.ini?
Так?
Back to top
View user's profile Send private message
-=Vovka=-
Заглянувший



Joined: 17 Feb 2015
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Tue Feb 17, 2015 12:00 pm (спустя 1 год 5 месяцев 2 дня 18 часов 13 минут; написано за 2 минуты 55 секунд)
   Post subject:
Reply with quote

Появилась проблема с утановкой PHP версии 5.6. Стоит последний Денвер-3.
Скачал с сайта windows.php.net/downloads/releases/php-5.6.5-nts-Win32-VC11-x86.zip архив, распаковал в каталог php5 Денвера, запускаю php.exe - выдает, что этот файл "Не является приложением Win32".

Как поступить?
Back to top
View user's profile Send private message
vitalino87
Заглянувший



Joined: 17 Mar 2018
Posts: 3
Карма: 0
   поощрить/наказать


PostPosted: Sat Mar 17, 2018 8:29 am (спустя 3 года 27 дней 20 часов 28 минут; написано за 23 секунды)
   Post subject:
Reply with quote

Я скачивал с нормального сайта, поэтому проблем с установкой у меня не было. Рекомендую всем выбирать нормальные источники!
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Page 1 of 1    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML