Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

После переустановки иногда не дает открывать страницы (Андрей Л.)
Author Message
Андрей Л.
Guest





Карма: 387
   поощрить/наказать


PostPosted: Tue Feb 17, 2009 10:46 am (написано за 5 минут 34 секунды)
   Post subject: После переустановки иногда не дает открывать страницы
Reply with quote

У меня был старый Денвер (2003г.) Все на нем работало. Решил установить новый и обновить перл. Скопировал home на флешку, установил новый денвер, установил новый перл, проверил тестовые страницы -- все Ок. Вернул обратно папку home со своими проектами, проекты открываются, но с багами: при переходах часто выдает, что не найдено., в логах ничего не пишет. Подскажите, что мне делать? Ведь раньше все работало! Или подскажите, что для диагностики надо расписать здесь подробнее.
Back to top
Александр Михалицын
Модератор



Joined: 23 May 2008
Posts: 1299
Карма: 81
   поощрить/наказать


PostPosted: Tue Feb 17, 2009 11:23 am (спустя 37 минут; написано за 4 секунды)
   Post subject:
Reply with quote

Андрей Л.,
forum.dklab.ru/viewtopic.php?t=20602
Back to top
View user's profile Send private message Send e-mail
Guest






Карма: 387
   поощрить/наказать


PostPosted: Tue Feb 17, 2009 11:48 am (спустя 24 минуты; написано за 3 минуты 43 секунды)
   Post subject:
Reply with quote

Да, еще был момент: после установки денвера и перла установил 3 перл-модуля прямо из интернета. Может, они что побили?

Проблемы, например, такие (раньше все работало):
Открываю страницу (генерируется через SSI с помощью перл-скрипта -- все Ок.
По ссылке с этой страницы перехожу в режим редактирования (вход по паролю, все .htaccess и .htpasswd те же, что и раньше) -- не пускает, вернее, сразу вылетает страница с ошибкой Internal Server Error. В логах никакой записи не делается. Вввожу адрес той же запороленной страницы вручную -- открывается нормально. При переходе по ссылкам та же картина: то есть, то нет. И так на всех сайтах. Раньше проблем никаких не было, все работало. Логи теперь всегда молчат.

Пока писал, появилось сообщение. Спасибо!

Заглянул в логи аппача, там еть ошибки. Вот по описанному при заходе по ссылке:


[Tue Feb 17 11:27:20 2009] [error] [client 127.0.0.1] Z:/home/bla-bla.ru/cgi-bin/admin/index.html is not executable; ensure interpreted scripts have "#!" first line, referer: www.bla-bla.ru/

[Tue Feb 17 11:27:20 2009] [error] [client 127.0.0.1] (9)Bad file descriptor: don't know how to spawn child process: Z:/home/bla-bla.ru/cgi-bin/admin/index.html, referer: www.bla-bla.ru/

Если открываю сразу вводя УРЛ, открывается и ничего не пишет в ошибках.
Back to top
Guest






Карма: 387
   поощрить/наказать


PostPosted: Tue Feb 17, 2009 11:58 am (спустя 9 минут; написано за 4 минуты 45 секунд)
   Post subject:
Reply with quote

Ой, по ссылке пытаюсь открыть файл .html, а при открытии при задании УРЛ открываю скрипт. .html тоже не катит.

У меня на конкретном сайте в папке www в .htaccess прописано:

AddHandler server-parsed .html

И это раньше действовало на весь сайт, в том числе и папку cgi-bin/admin

Там в .htaccess такой записи нет, а ссылки идут по файлам .html.

Прописал такую строку в .htaccess папки cgi-bin/admin, заработало как надо.
Back to top
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9993
   поощрить/наказать


PostPosted: Tue Feb 17, 2009 4:14 pm (спустя 4 часа 16 минут)
   Post subject:
Reply with quote


М

Перенесено из форума: Баги (не-баги Денвера здесь запрещены!) :: Денвер.
Перенесено в форум: Разное :: Perl.
Back to top
View user's profile Send private message
Ant
Сотрудник «Лаборатории»



Joined: 17 Jun 2003
Posts: 6837
Карма: 131
   поощрить/наказать


PostPosted: Tue Jan 24, 2012 3:24 pm (спустя 2 года 11 месяцев 6 дней 23 часа 9 минут; написано за 22 секунды)
   Post subject:
Reply with quote


М

Вообще, я склоняюсь к тому, что Perl тут не при чём.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Page 1 of 1    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You cannot download files in this forum.
XML