Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

Установка библиотеки fann (kdinisv)
Author Message
kdinisv
Заглянувший



Joined: 23 Nov 2009
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Mon Nov 23, 2009 10:51 pm (написано за 2 минуты 4 секунды)
   Post subject: Установка библиотеки fann
Reply with quote

Здравствуйте, у меня никак не получается поставить расширение fann leenissen.dk/fann/ на pear на windows.
В cmd ввожу pear install fann, он думает и выводит следующее:
Code (Windows BAT file): скопировать код в буфер обмена
No releases available for package "pear.php.net/fann" - package pecl/fann can be
installed with "pecl install fann"
Cannot initialize 'channel://pear.php.net/fann', invalid or missing package file
Package "channel://pear.php.net/fann" is not valid
install failed
Пробую через pecl:
В cmd ввожу pecl install -f fann, мне выводит следующее
Code (Windows BAT file): скопировать код в буфер обмена
WARNING: failed to download pecl.php.net/fann within preferred state "stable", w
ill instead download version 0.1.1, stability "devel"
downloading fann-0.1.1.tgz ...
Starting to download fann-0.1.1.tgz (9,509 bytes)
.....done: 9,509 bytes
3 source files, building
WARNING: php_bin H:\WebServer\usr\local\php5\.\php.exe appears to have a suffix
5\.\php.exe, but config variable php_suffix does not match
ERROR: The DSP fann.dsp does not exist.
Пробовал конкретную версию писать, тоже самое. В чем причина?
Back to top
View user's profile Send private message
Tim Burton
Заглянувший



Joined: 06 Jan 2011
Posts: 2
Карма: 1
   поощрить/наказать


PostPosted: Thu Jan 06, 2011 7:38 pm (спустя 1 год 1 месяц 12 дней 20 часов 46 минут; написано за 31 секунду)
   Post subject:
Reply with quote

У меня идентичная проблема ...
выполнение из коммандной строки
Code (php): скопировать код в буфер обмена
pecl.bat config-set php_suffix .exe
убрало сообщение ...
Code (php): скопировать код в буфер обмена
WARNING: php_bin H:\WebServer\usr\local\php5\.\php.exe appears to have a suffix
5\.\php.exe, but config variable php_suffix does not match
но установить так и не удалось ...
Code (php): скопировать код в буфер обмена
D:\web\usr\local\php5>pecl.bat install -f fann
WARNING: failed to download pecl.php.net/fann within preferred state "stable", w
ill instead download version 0.1.1, stability "devel"
downloading fann-0.1.1.tgz ...
Starting to download fann-0.1.1.tgz (9,509 bytes)
.....done: 9,509 bytes
3 source files, building
ERROR: The DSP fann.dsp does not exist.
как решить трабл?
Back to top
View user's profile Send private message
Tim Burton
Заглянувший



Joined: 06 Jan 2011
Posts: 2
Карма: 1
   поощрить/наказать


PostPosted: Fri Jan 07, 2011 2:05 am (спустя 6 часов 27 минут; написано за 1 минуту 11 секунд)
   Post subject:
Reply with quote

проблема решена.
после долгих часов мучений ...
в архиве два файла, в подписях описано куда нужно распаковывать ...
в php.ini добавляем extension=php_fann.dll

Вопрос решен, тему можно закрыть.


working_example.rar
 Description:
работающий пример ...

Download
 Filename:  working_example.rar
 Filesize:  2.44 KB
 Downloaded:  818 Time(s)


php_fannDLL.rar
 Description:
Распаковуем в PHPext

Download
 Filename:  php_fannDLL.rar
 Filesize:  10.85 KB
 Downloaded:  890 Time(s)


fanndoubleMTDLL.rar
 Description:
Распаковуем в WINDOWSsystem32

Download
 Filename:  fanndoubleMTDLL.rar
 Filesize:  75.94 KB
 Downloaded:  821 Time(s)

Back to top
View user's profile Send private message
profitweb
Заглянувший



Joined: 08 Mar 2012
Posts: 1
Карма: 0
   поощрить/наказать


PostPosted: Thu Mar 08, 2012 4:54 pm (спустя 1 год 2 месяца 1 день 14 часов 48 минут; написано за 54 секунды)
   Post subject:
Reply with quote

народ подскажите пожалуйста как собрать эти 2 файла под версию 1.1
Back to top
View user's profile Send private message
parser4u
Заглянувший



Joined: 04 Nov 2012
Posts: 1
Карма: -1
   поощрить/наказать

Location: Украина

PostPosted: Sun Nov 04, 2012 3:34 am (спустя 7 месяцев 26 дней 10 часов 39 минут; написано за 1 минуту 24 секунды)
   Post subject:
Reply with quote

сделал как описывал Tim Burton прошло без ошибок, но при запуске денвера в логе имеется следующее:
Code (any language): скопировать код в буфер обмена
PHP Warning:  PHP Startup: Fann 2.1.0 Extension (Double mode): Unable to initialize module
Module compiled with module API=20060613
PHP    compiled with module API=20090626
These options need to match
in Unknown on line 0
кто сталкивался - подскажите как решить
Back to top
View user's profile Send private message
bæv
Модератор «Дзена»



Joined: 27 Aug 2003
Posts: 7275
Карма: 9989
   поощрить/наказать


PostPosted: Mon Nov 05, 2012 2:30 pm (спустя 1 день 10 часов 55 минут; написано за 1 минуту 26 секунд)
   Post subject:
Reply with quote

parser4u wrote:
Module compiled with module API=20060613
PHP compiled with module API=20090626
— и что непонятно?
Расширение и php должны быть скомпилированы компилятором одной версии.
Ищите расширение, скомпилированное VC9, или компилируйте сами.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic All times are GMT + 3 Hours
Page 1 of 1    Email to a Friend.
You cannot post new topics in this forum. You cannot reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You can download files in this forum.
XML