Форум dkLab и Denwer
Здесь общаются Web-разработчики.
Генеральный спонсор:
Хостинг «Джино»

[2001-12-13 21:29] Вопрос посетителя Вашего сайта (mail: Serge)
Author Message
mail: Serge
Guest





Карма: 388
   поощрить/наказать


PostPosted: Sat Oct 18, 2003 4:45 pm ()
   Post subject: [2001-12-13 21:29] Вопрос посетителя Вашего сайта
Reply with quote

Здравствуйте!
Спасибо за Вашу толковую и очень понятную статью.
Также заранее спасибо за Вашу готовность помочь советом.
Вкратце моя проблема такова:

У меня уже был установлен ActivePerl (версия 5 с чем-то)
в каталоге C:\Perl
Потом скачал и установил Apache 1.3.12
Произвел настройки в соответствии с Вашими рекомендациями.
(PHP и MySQL пока не затрагивал)
Работает хорошо все, за исключением PERL-скриптов, даже
на предложенный Вами test.pl браузер выдает 'ошибку 500'
Подозреваю, что это потому, что в файле httpd.conf я так
и не смог отыскать упомянутую Вами строку:
ScriptInterpreterSource registry
Скажите пожалуйста, зависит ли это от версии Апача?
Может быть, PERL следует устанавливать после Apache?

И еще, я так и не понял разницы между
#!usr/local/bin/perl и
#!usr/bin/perl
мой хостинг-провайдер, например, предполагает второй
вариант, а в Вашей статье приводится только первый.

С уважением
Сергей Гришин

segri@mail.ru setentrion@mtu.ru www.feira.ru
Back to top
mail: Dmitry Koteroff
Guest





Карма: 388
   поощрить/наказать


PostPosted: Sat Oct 18, 2003 4:45 pm (спустя 3 секунды)
   Post subject: [2003-10-18 13:45] Вопрос посетителя Вашего сайта
Reply with quote

> У меня уже был установлен ActivePerl (версия 5 с чем-то) > в каталоге C:\Perl > Потом скачал и установил Apache 1.3.12 > Произвел настройки в соответствии с Вашими рекомендациями. > (PHP и MySQL пока не затрагивал) > Работает хорошо все, за исключением PERL-скриптов, даже > на предложенный Вами test.pl браузер выдает 'ошибку 500' > Подозреваю, что это потому, что в файле httpd.conf я так > и не смог отыскать упомянутую Вами строку: > ScriptInterpreterSource registry > Скажите пожалуйста, зависит ли это от версии Апача? > Может быть, PERL следует устанавливать после Apache? Да, зависит - у Вас слишком старая версия. Нужно не ниже 1.3.14.
> И еще, я так и не понял разницы между > #!usr/local/bin/perl и > #!usr/bin/perl > мой хостинг-провайдер, например, предполагает второй > вариант, а в Вашей статье приводится только первый. У хорошего хостинг-провайдера, который заботится о своих
клиентах, будут работать оба варианта. ;-) Конечно, если после
"!" поставить "/".
Back to top
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. All times are GMT + 3 Hours
Page 1 of 1    Email to a Friend.
You can post new topics in this forum. You can reply to topics in this forum. You cannot edit your posts in this forum. You cannot delete your posts in this forum. You cannot vote in polls in this forum. You cannot attach files in this forum. You cannot download files in this forum.
XML